Service Disruption for Katalon TestOps, TestCloud and TrueTest

Incident Report for Katalon

Resolved

Thank you for your patience, we are happy to report that service has been restored for all Katalon services. Our teams are continuing to monitor our systems.
Posted Oct 21, 2025 - 02:15 UTC

Update

Thank you for your patience while our teams work to maintain service for Katalon Users.

Due to ongoing issues with our hosting provider, authentication services are currently blocked. Users can expect timeout errors and significantly degraded service when attempting to sign in to any Katalon products. We are exploring several ways to restore functionality as soon as possible.
Posted Oct 20, 2025 - 20:05 UTC

Update

We are continuing to investigate this issue.
Posted Oct 20, 2025 - 08:52 UTC

Investigating

We are currently investigating a service disruption affecting Katalon TestOps. The issue is related to a wider outage reported by our cloud provider, Amazon Web Services (AWS), which impacts our underlying infrastructure.

​Our engineering team is actively monitoring the situation and developing workarounds to restore service as quickly as possible.

​We sincerely apologize for any inconvenience this may cause. Our next update will be provided as soon as more information becomes available.
Posted Oct 20, 2025 - 08:12 UTC
This incident affected: TestOps (TestOps Login, Licensing, Agent), TestCloud (TestCloud Metering Service, TestCloud Main Service, TestCloud Provisioning Service, TestCloud Tunnel Service), Katalon Website (Account Management, Admin Homepage), and TrueTest.