TestOps Gen3 — Newly synced Git test assets not appearing (US)

Incident Report for Katalon

Resolved

This incident has been resolved.
Posted Jul 02, 2026 - 12:20 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 02, 2026 - 11:47 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Jul 02, 2026 - 11:01 UTC

Investigating

We are investigating an issue in TestOps Gen3 (US) where, after connecting or syncing a Git repository, newly synced test assets - test cases, test suites, test suite collections, and execution profiles - may not appear. As a result, running tests from a newly Git-synced repository may be blocked.
Repositories that were previously synced and are already indexed are not affected, and no data has been lost - your repository contents in Git are safe. Our engineering team is actively working on a fix and a re-sync to restore visibility. Next update within 60 minutes.
Posted Jul 02, 2026 - 09:55 UTC
This incident affected: [True Platform] TestOps (Executions (US), TestOps API (US)).