Incident: Intermittent Failures and Cancellations in TestOps Executions

Incident Report for Katalon

Resolved

This incident has been resolved.
Posted Dec 03, 2025 - 14:28 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Dec 03, 2025 - 13:13 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Dec 03, 2025 - 12:43 UTC

Investigating

We are currently investigating an issue affecting TestOps executions utilizing TestCloud. Users may experience instability with scheduled test runs.

Our engineering team has reproduced this behavior and identified it as a platform-side issue. We are working urgently to restore normal execution stability.
Posted Dec 03, 2025 - 11:30 UTC
This incident affected: TestOps (Executions).